Project

General

Profile

Actions

Feature #4347

closed

Contributing to an issue should automatically add the user to the watchers list

Added by Kamil . over 14 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Category:
Issues
Target version:
Start date:
2009-12-06
Due date:
% Done:

0%

Estimated time:
Resolution:
Fixed

Description

When an user replies to an issue, he/she is definatelly interested in it, so I think that it is natural to add him/her to watchers list automatically, so he/she could obtain notification e-mails.


Files

my-account.png (94.6 KB) my-account.png Takenori TAKAKI, 2019-03-07 01:42
users-new.png (82.7 KB) users-new.png Takenori TAKAKI, 2019-03-07 01:42
enable-to-setting-auto-watch-by-account.patch (6.63 KB) enable-to-setting-auto-watch-by-account.patch Takenori TAKAKI, 2019-03-07 01:44
autowatch.png (19.2 KB) autowatch.png Jens Krämer, 2021-04-21 05:01
0001-auto-watch-issues-a-user-contributes-to.patch (7.33 KB) 0001-auto-watch-issues-a-user-contributes-to.patch rebased on master / 20210420 (corrected patch) Jens Krämer, 2021-04-21 05:07

Related issues

Related to Redmine - Feature #1737: autowatch issuesClosed2008-08-03

Actions
Related to Redmine - Feature #2716: User option to automatically add assignee to watchersNewMarius BĂLTEANU2009-02-11

Actions
Related to Redmine - Feature #38238: Auto watch issues on issue creationClosedGo MAEDA

Actions
Has duplicate Redmine - Feature #8523: "Notify if I'm involved" should trip if I've commented on an issueClosed

Actions
Has duplicate Redmine - Feature #11520: Make issue be watched automatically when posting to itClosed

Actions
Has duplicate Redmine - Feature #11405: Add users as watcher when they leave a comment (Bugzilla parity)Closed

Actions
Actions #1

Updated by Udit Sajjanhar over 14 years ago

Rather than doing it for any user who leaves comment, there could be a "Watch this issue" check box in the Update issue form.

The admin can choose whether this checkbox will be checked or unchecked by default.

WDYT?

Actions #2

Updated by Felix Schäfer over 14 years ago

Well, I wouldn't mind being made watcher by default, as is already the case for the forum, but I'm not sure that would fly for everyone. On the other hand, I'm not sure if it should be an option for every response or comment you give, because most of the time, you have a personal default for such things. What about making it a user preference, i.e. "I want to watch Issues and Forum Threads to which I respond" or something like that?

Actions #3

Updated by Kamil . over 14 years ago

Felix Schäfer wrote:

"I want to watch Issues and Forum Threads to which I respond" or something like that?

Nice idea

Actions #4

Updated by Robert Chady over 14 years ago

FYI, I wrote a plugin called auto_watchers that almost does this for you. It currently adds people that the issue gets assigned to OR any person that modifies the issue as watchers. It is available on my github account at http://github.com/rchady. No promises on it, but for my use it has been working well. Personally, I feel that features like this one should be kept in a plugin rather than added to the core, just my $.02.

Actions #5

Updated by Udit Sajjanhar over 14 years ago

Kamil . wrote:

Felix Schäfer wrote:

"I want to watch Issues and Forum Threads to which I respond" or something like that?

Nice idea

+1 for this
Actions #6

Updated by Kamil . over 14 years ago

Robert Chady wrote:

I feel that features like this one should be kept in a plugin rather than added to the core, just my $.02.

I do not agree. This should be a basic functionality (like in the forum)

Actions #7

Updated by Jean-Philippe Lang over 14 years ago

  • Category set to Issues
Actions #8

Updated by Fernando Hartmann about 14 years ago

+1 it's very useful

Actions #9

Updated by Adam Piotr Żochowski about 14 years ago

Allow this to be a triple setup

  • Per whole system (any reply becomes watcher)
  • Per project (only replies to specific projects make a person a watcher)
  • per person (only people that want to be watchers on a reply become watchers)

Different people/projects might operate on different setups.

Actions #10

Updated by Paul Dann over 13 years ago

This seems like a really important feature to me; I was surprised to discover that there hasn't been much work on this so far. Any chance of increasing the priority on this?

Actions #11

Updated by Sebastian M almost 13 years ago

About to give rchady's plugin a shot. Looks good. Thanks.

Actions #12

Updated by Jimmy Praet over 8 years ago

+1

Actions #13

Updated by Go MAEDA about 8 years ago

  • Has duplicate Feature #11520: Make issue be watched automatically when posting to it added
Actions #14

Updated by Go MAEDA about 8 years ago

  • Has duplicate Feature #11405: Add users as watcher when they leave a comment (Bugzilla parity) added
Actions #15

Updated by Go MAEDA about 8 years ago

Actions #16

Updated by Oscar Santos over 7 years ago

+1 We really need this functionality. The plugins that were developed for this are no longer compatible and have not been updated to support the latest versions of Redmine. Please implement this Auto Watch feature. Thank you.

Actions #17

Updated by Tobias Fischer over 7 years ago

This is a duplicate of older issue #2716

Actions #18

Updated by Tobias Fischer over 7 years ago

# And wrote in #2716-12:

Try it out: https://github.com/logical-and/redmine_auto_watch. Watchers added on issue update and issue create from: author, assignee, previous assignee if any.

I can confirm that the forked and enhanced version of this plugin which can be found at https://github.com/mephi-ut/redmine_auto_watch works very well for Redmine 3.3.1

Actions #19

Updated by Toshi MARUYAMA over 7 years ago

  • Related to Feature #2716: User option to automatically add assignee to watchers added
Actions #20

Updated by Takenori TAKAKI about 5 years ago

I propose the following features for auto watch.
  • User is added as a watcher automatically, When adding a comment to an issue.
  • Enable to select "Auto watch" ON / OFF on Account Settings (Default is ON).
  • When adding a feature, the existing users's setting is OFF, and After adding a feature, the newly created user's setting is ON by default.

I made a patch and attach it.

('my/account' screen)

('users/new' screen)

Actions #21

Updated by Kamil . about 5 years ago

nice!

Actions #22

Updated by Mitsuyoshi Kawabata about 5 years ago

Great!

Actions #23

Updated by Go MAEDA about 5 years ago

  • Target version set to Candidate for next major release
Actions #24

Updated by Akihiro YAMAKAWA almost 5 years ago

+1 Great work!

Actions #25

Updated by Vasili Korol almost 5 years ago

This is a very nice feature indeed. I suggest re-phrasing "Issues I added notes" to "Issues I comment on".

Actions #26

Updated by Matthias Reinhardt about 4 years ago

+1

Actions #27

Updated by Jens Krämer about 3 years ago

+1

I rebased the patch on current master and slightly changed wording and layout of the user setting:

Actions #28

Updated by Jens Krämer about 3 years ago

please discard the previous patch, it contained some unnecessary files. here's the correct patch.

Actions #29

Updated by Go MAEDA about 3 years ago

  • File deleted (0001-auto-watch-issues-a-user-contributes-to.patch)
Actions #30

Updated by Go MAEDA about 3 years ago

  • Target version changed from Candidate for next major release to 5.0.0

Setting the target version to 5.0.0.

Actions #31

Updated by Marius BĂLTEANU about 3 years ago

The patch proposed add the current user as watcher for any action made on the issue, not only for "add notes" action. To reproduce, edit an issue attribute without adding any note and observe that the current user is added to the watcher list.

Is this the expected behaviour? Or we should have more granular actions: add note (this issue), assigned to me (#2716) and all actions (the behaviour implemented by the proposed patch).

Actions #32

Updated by Walter Thompson about 2 years ago

Is there a version of this that would work with Redmine Version 4.2.3.stable?

Actions #33

Updated by Marius BĂLTEANU about 2 years ago

  • Assignee set to Marius BĂLTEANU
Actions #34

Updated by Marius BĂLTEANU about 2 years ago

  • Status changed from New to Resolved
  • Resolution set to Fixed

Patch committed with a slight change, I've renamed the internal option name from add_note to issue_contributed_to in order to match the behaviour and allow future developments.

If it's really required, we can add more granular options, but for now I think it's enough.

Actions #35

Updated by Marius BĂLTEANU about 2 years ago

  • Subject changed from Replying to an issue should automatically add the user to the watchers list to Contributing to an issue should automatically add the user to the watchers list
Actions #36

Updated by Marius BĂLTEANU about 2 years ago

  • Status changed from Resolved to Closed
Actions #37

Updated by Go MAEDA over 1 year ago

  • Related to Feature #38238: Auto watch issues on issue creation added
Actions

Also available in: Atom PDF