Patch #14318

Watchers Alerted To Changes But Cannot See Issues (potentially)

Added by Brett Patterson over 4 years ago. Updated 3 months ago.

Status:ClosedStart date:
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:Issues permissions
Target version:-

Description

At our company we try to keep things private so user A cannot see tickets from user B. With this in mind, I set the Issues Visibility setting for all user groups to be the assigned to or created by me value. This has the draw back that if I add a watcher because it may not directly implicate that person but they need to be kept in the loop (e.g. supervisor/boss), they would get the email updates but can't see the issue within Redmine itself.

So I added two more options to the Issue Visibility dropdown:

  1. Created by, Assigned to, or watched by the user
  2. Created by, Assigned to, watched by, or contributed to by the user

The contributed to just looks at the journals of the issues to see if you've modified the issue in some way (meaning you now have a vested interest in the issue).

Attached is the patch I developed against the core of 2.2.3. I haven't tested it in the 3.x line yet, but hope to soon.

Hopefully this could be wrapped into 2.2.5 or the next 3.x release.

allow_watchers_and_contributers_access_to_issues.patch Magnifier (3.31 KB) Brett Patterson, 2013-06-19 22:13

roles-edit.png - screenshot (roles/edit) (35.9 KB) Go MAEDA, 2016-01-16 07:05

allow_watchers_and_contributers_access_to_issues_v2.patch Magnifier - patch for 3.2.0.devel.15058 (3.28 KB) Go MAEDA, 2016-02-04 14:30

allow_watchers_and_contributers_access_to_issues_trunk_r15287.patch Magnifier (7.4 KB) Takenori TAKAKI, 2016-03-29 04:13

allow_watchers_and_contributers_access_to_issues_3.2.0.patch Magnifier (7.43 KB) Fabrizio Sebastiani, 2016-04-06 23:26

allow_watchers_and_contributers_access_to_issues_3.3.0.patch Magnifier - for Redmine 3.3.x (7.41 KB) Tobias Fischer, 2017-08-08 16:23

allow_watchers_and_contributers_access_to_issues_3.4.2.patch Magnifier - for Redmine 3.4.2 (and probably later) (7.47 KB) Tobias Fischer, 2017-08-08 17:16


Related issues

Related to Redmine - Patch #23546: Issue visibility "watched by, created by or assigned to" ... New
Duplicates Redmine - Feature #8488: Create an 'Involve' mechanism to private issues New

History

#1 Updated by Jan Niggemann (redmine.org team member) over 4 years ago

Good idea, thank you for your patch!

#2 Updated by Brett Patterson about 4 years ago

I've sent this patch in as a pull request to the github repo. The patch above should work on the 2.3.x branch. The only difference are line numbers might be off slightly.

https://github.com/redmine/redmine/pull/15

I know github isn't the official way, but I'm still hopeful this will be integrated.

#3 Updated by Brett Patterson almost 4 years ago

callesg tested with 2.4.1-devel and said it works. I'm working on testing it as well.

#4 Updated by Brett Patterson almost 4 years ago

I can confirm the patch works with 2.4.1. I manually did the patching, but the same changes do work.

#5 Updated by Brett Patterson over 3 years ago

Jean-Baptiste Barth closed the pull request on GitHub; however, no note here even though I referenced the ticket on GitHub. The patch is attached to the original ticket. Please consider merging this in with the next release.

#6 Updated by Toshi MARUYAMA over 3 years ago

  • Related to Defect #17071: Adding Watchers UX Is Not Clean added

#7 Updated by Go MAEDA almost 2 years ago

  • Target version set to Candidate for next major release

Wonderful feature. I really want to see this in 3.3 relase.
Updated the patch for Redmine 3.2.0.devel.15058. Works fine for me. All that remains is to add tests.

#8 Updated by Go MAEDA almost 2 years ago

Here is a screenshot.

screenshot (roles/edit)

#9 Updated by Go MAEDA almost 2 years ago

  • Related to Feature #16845: Add permission rule to allow watchers can edit issues added

#10 Updated by Go MAEDA almost 2 years ago

  • Duplicated by Feature #20106: Adding issue watchers to "Issues Visibility" permissions added

#11 Updated by Go MAEDA almost 2 years ago

  • Duplicated by Feature #13828: when users can only see their own issues; give watchers the ability to view issues they watch added

#12 Updated by Hang Xie almost 2 years ago

patch to Redmine 3.2.0, work fine!
it's better than the patch of #8488

#13 Updated by Emrah KAVUN almost 2 years ago

Go MAEDA wrote:

Updated the patch for Redmine 3.2.0.devel.15058. Works fine for me. All that remains is to add tests.

Are we able to get the updated version somewhere?

Thanks

#14 Updated by Go MAEDA almost 2 years ago

Emrah KAVUN wrote:

Go MAEDA wrote:

Updated the patch for Redmine 3.2.0.devel.15058. Works fine for me. All that remains is to add tests.

Are we able to get the updated version somewhere?

Thanks

Sorry, I forgot to attach the file.
Submitting again: allow_watchers_and_contributers_access_to_issues_v2.patch

#15 Updated by Toshi MARUYAMA over 1 year ago

  • Related to Feature #21909: Issues visibility in roles: Issues where user is a watcher added

#16 Updated by Toshi MARUYAMA over 1 year ago

  • Related to deleted (Feature #21909: Issues visibility in roles: Issues where user is a watcher)

#17 Updated by Go MAEDA over 1 year ago

  • Duplicated by Feature #8858: Extend new issue visibility criteria: issues created by or assigned to the user added

#18 Updated by Takenori TAKAKI over 1 year ago

Go MAEDA wrote:

Wonderful feature. I really want to see this in 3.3 relase.
Updated the patch for Redmine 3.2.0.devel.15058. Works fine for me. All that remains is to add tests.

I have updated the patch for below:
  • Compatible with latest trunk (r15287)
  • Added tests

I also really want to see this in 3.3 relase.

#19 Updated by Fernando Hartmann over 1 year ago

Takenori TAKAKI wrote:

I also really want to see this in 3.3 relase.

+1

#20 Updated by Vedat Kamer over 1 year ago

Fernando Hartmann wrote:

Takenori TAKAKI wrote:

I also really want to see this in 3.3 relase.

+1

+1

#21 Updated by Go MAEDA over 1 year ago

  • Target version changed from Candidate for next major release to 3.3.0

Takenori TAKAKI wrote:

I have updated the patch for below:
  • Compatible with latest trunk (r15287)
  • Added tests

Thanks for adding tests!
The patch works fine and passed all tests. I think we can merge this patch. Setting target version to 3.3.0.

#22 Updated by Fabrizio Sebastiani over 1 year ago

I tested right now a patch derived from Takenori TAKAKI's one allow_watchers_and_contributers_access_to_issues_trunk_r15287.patch
but since i have a 2.3.0 stable, I have arranged it and I provide it here as allow_watchers_and_contributers_access_to_issues_3.2.0.patch it have some little differences.

apply it with -p1 to avoid errors:

# cd /my/redmine/root/dir/2.3.0-stable
# ls -d vendor app extra lib bin config README.rdoc 
app  bin  config  extra  lib  README.rdoc  vendor
# patch -p1 < /somewhere/allow_watchers_and_contributers_access_to_issues_3.2.0.patch

I didn't run test functions, sorry.

Thank you for this patch and candidate for next release. We are getting a good experience with redmine as a new tool in company: this functionality is absolutely important for us.

#23 Updated by Jean-Philippe Lang over 1 year ago

  • Status changed from New to Closed
  • Target version deleted (3.3.0)

This is the same as #8488. Using watchers as a way to give access to issues was already discussed, please see #7412#note-13.

#24 Updated by Jean-Philippe Lang over 1 year ago

  • Related to deleted (Feature #16845: Add permission rule to allow watchers can edit issues)

#25 Updated by Jean-Philippe Lang over 1 year ago

  • Duplicated by deleted (Feature #13828: when users can only see their own issues; give watchers the ability to view issues they watch)

#26 Updated by Jean-Philippe Lang over 1 year ago

  • Duplicated by deleted (Feature #20106: Adding issue watchers to "Issues Visibility" permissions)

#27 Updated by Jean-Philippe Lang over 1 year ago

  • Duplicated by deleted (Feature #8858: Extend new issue visibility criteria: issues created by or assigned to the user)

#28 Updated by Jean-Philippe Lang over 1 year ago

  • Related to deleted (Defect #17071: Adding Watchers UX Is Not Clean)

#29 Updated by Jean-Philippe Lang over 1 year ago

  • Related to Feature #8488: Create an 'Involve' mechanism to private issues added

#30 Updated by Jean-Philippe Lang over 1 year ago

  • Related to deleted (Feature #8488: Create an 'Involve' mechanism to private issues)

#31 Updated by Jean-Philippe Lang over 1 year ago

  • Duplicates Feature #8488: Create an 'Involve' mechanism to private issues added

#32 Updated by Tobias Fischer over 1 year ago

There's ongoing discussion in #8488.
But for those landing here in this ticket I can confirm allow_watchers_and_contributers_access_to_issues_3.2.0.patch works well for 3.2.3.stable.15464

#33 Updated by Jan from Planio www.plan.io over 1 year ago

  • Related to Patch #23546: Issue visibility "watched by, created by or assigned to" for roles added

#34 Updated by Peter Brogren 10 months ago

We agree that this is functionality that should get merged in, as soon as possible. On the subject of confusing, we believe it is very confusing for someone to get the notification as a watcher but then not be able to log in and see the issue. We do use a modified patch of this and frequently use the method of adding someone as a watcher as a way to allow ("invite") someone to see what happens with a certain private (secret!) issue, i.e. get the email notifications AND be able to log in and see the issue. If such person then decides to "unwatch" the issue, it seems OK with everyone that you no longer get the emails AND are no longer able to see the issue. After all you decided to "unwatch" the issue, i.e. you specifically said you don't want to see (watch) it anymore! Please merge at the earliest convenience!

#35 Updated by Tobias Fischer 3 months ago

The attached patch is an updated version of allow_watchers_and_contributers_access_to_issues_3.2.0.patch which works for 3.3.x
Needs to be run from redmine install root dir.

#36 Updated by Tobias Fischer 3 months ago

And this patch was made against Redmine 3.4.2 and I can confirm it works.

Also available in: Atom PDF