Project

General

Profile

Actions

Feature #1011

open

Add voting to tickets

Added by Maxim Krušina about 16 years ago. Updated about 5 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Issues
Target version:
-
Start date:
2008-04-07
Due date:
% Done:

0%

Estimated time:
Resolution:

Description

As I see lot of people voting for different tickets, I got idea why not to add voting to tickets.
Here is my rough idea:
  • Voting can be enabled/disabled per project/tracer
    • so some projects will have no voting, some projects will have voting, but in some trackers (probably we don't vote in "bugs" tracker)
  • Every user can give only one vote per ticket
    • so voting will be for registered users only (probably)
  • Proposal of voting model:
    • Simple: you can vote (+1) or not vote (0)
    • 1-5 model: you can select "how much" you vote: 5 = very much, 1 = maybe...
    • -1,0,+1 model: you can vote in positive or negative way...
  • Each ticket will display voting score (numbers of points) and number of votes (this apply based on exact voting model)
  • When Nr. of votes and/of voting score will be added to ticket list's filters, we can list tickets by voting score or number of votes
  • Top 10 (5 etc) of most wanted issues can be displayed on homepage of project

What others think?


Files

likes.png (302 KB) likes.png Konstantin Ladutenko, 2017-02-15 18:50

Related issues

Related to Redmine - Feature #8299: Add "vote for this issue" button on issuesClosed2011-05-05

Actions
Related to Redmine - Feature #6945: Add a voting system to help users help admins identify popular features/defectsNewJean-Philippe Lang2010-11-19

Actions
Related to Redmine - Feature #1158: Polls New2008-05-01

Actions
Related to Redmine - Feature #17288: Use Watcher Count as a poor man's Voting system on redmine.orgNew

Actions
Related to Redmine - Feature #24946: Issue rating (like button or vote up button)New

Actions
Has duplicate Redmine - Feature #8478: Vote for featureClosed2011-05-31

Actions
Has duplicate Redmine - Feature #11200: Creare a vote system for users requestsClosedJean-Philippe Lang

Actions
Has duplicate Redmine - Feature #16050: Add votesClosed

Actions
Has duplicate Redmine - Feature #11655: Implementation of a Issue VotingClosed

Actions
Actions #1

Updated by Ale Muñoz about 16 years ago

I'd say +1 for this : )

Actions #2

Updated by Maxim Krušina about 16 years ago

Yes, +1 for me too ;)

Actions #3

Updated by Rocco Stanzione about 16 years ago

+1. May be a good candidate for a plugin.

Actions #4

Updated by Raz Mataz about 16 years ago

+1 from me, too

Actions #5

Updated by F. D. Castel about 16 years ago

+1 here.

(Hey! We are VOTING here... Nice hack. :) )

Actions #6

Updated by Leandro Lucarella about 16 years ago

+1

Actions #7

Updated by Arthaey Angosii about 16 years ago

+1. See http://www.uservoice.com/ for a clean example of simple issue-voting.

Actions #8

Updated by David Gillard about 16 years ago

+1

Actions #9

Updated by Roy Belview about 16 years ago

+1. This would be a really great feature!

Actions #10

Updated by Anonymous almost 16 years ago

+1

Actions #11

Updated by clawfrown clawfrown almost 16 years ago

+1 !

Actions #12

Updated by Marcello Henrique almost 16 years ago

+1 great!

Actions #13

Updated by clawfrown clawfrown almost 16 years ago

I believe simple model of voting will be the best.. Coz 5 stars and -1,0,+1 are weird..

Actions #14

Updated by Jan Losinski almost 16 years ago

+1

Actions #15

Updated by Curtis Stewart almost 16 years ago

+1 I could use it.

Actions #16

Updated by David Davis almost 16 years ago

Here's something that is 'sort of working for me': change the 'Issue priorities' Enumerations to [..., -1, 0, +1, +2, +3, ...] (as many as you need). This had the side-effect of making the 'priority' more relevant as well.

Then, the task would be to allow a non-manager 'user' to change the priority (explicitly?). Maybe 'voting' is a simple rule: a (non-manager/developer) 'user' can only change the priority, once, by one increment or decrement.

I was just toying with this solution as a workaround tonight, but thought it was interesting to implicitly tie the 'votes' to the 'priority' of an issue. Then the issues that are the 'squeakiest wheels' will automatically get the highest priorities.

Actions #17

Updated by Thomas Lecavelier almost 16 years ago

Like the idea and its description.

But that's another layer of cmoplexity: including it would move redmine closer to the bloated status :(

I preach for a plugin/module approach: let redmine admin add features they want to their very redmine, don't put all of them in it.

HTH

Actions #18

Updated by Mischa The Evil over 15 years ago

  • Status changed from New to 7
  • Assignee set to Mischa The Evil

I'll start some work for a plugin-implementation of issue-voting soon...
More to come...

Actions #19

Updated by Igor Tkachenko about 15 years ago

+1
I think this is a must have thing for every successful product aimed for end user!

On the first stages of product development when user community is small you may just write all users' suggestions to a paper sheet and easily see how many users want certain feature (this feature is wanted by 3 users and other features are wanted by only a one user, ok I'll do the first feature). But when the product community grows it's getting to hardly define what users want more. Without this feature you may think that users want EVERYTHING and RIGHT NOW! Having this feature allows us to plan what improvements we should implement first and what may wait for some time.

Actions #20

Updated by colin moock about 15 years ago

huge +1. every professional, public software project needs this.

Actions #21

Updated by colin moock about 15 years ago

notice that even redmine's issues are littered with +1 notes. those should all just be votes. every "+1" note in this system is a vote for ticket #1011.

Actions #22

Updated by Anonymous about 15 years ago

colin moock wrote:

notice that even redmine's issues are littered with +1 notes.

lol, that's a good point
oh yea... +1 ;p

Actions #23

Updated by Mischa The Evil about 15 years ago

  • Assignee deleted (Mischa The Evil)

Andrew Chaika developed an issue-voting plugin which probably solves this issue. It can be found here on the forums: Issue Vote Plugin.

Actions #24

Updated by Eric Davis about 15 years ago

  • Status changed from 7 to Closed
  • % Done changed from 0 to 100
  • Resolution set to Wont fix

Closing issue. Andrew Chaika has developed this in a plugin. See my comment for more information.

Actions #25

Updated by Kamil . over 14 years ago

What is the reason of not integrating this feature into trunk?
The best example is redmine.org itself, where users are voting constatnly still using comments.
If there would be necessity not to have voting - it should be possible to disable it in options.
What do you think?

Actions #26

Updated by James Turnbull over 14 years ago

Or just activate the voting plugin on Redmine.

Actions #27

Updated by Kamil . over 14 years ago

James Turnbull wrote:

Or just activate the voting plugin on Redmine.

That would be also a good solution, but if it is so desirable, why not to include it?

Actions #28

Updated by Ngewi Fet over 14 years ago

I agree that issue voting be used on redmine.org either as the plugin or in trunk
to eliminate the need for voting in comments which incidentally I am doing now.

Actions #29

Updated by Luiz Carlos Junior over 13 years ago

+1 (this is horrible)
Isn't it possible to add this feature to Redmine.org (into the trunk or as a plugin)?

Actions #30

Updated by Terence Mill over 13 years ago

It should be transparent to the comunity how ranking of features is. Else the future development can't be community driven.

+5 (new syntax - lol)

Actions #31

Updated by Sascha Herrmann over 13 years ago

+1 for activating this feature on redmine.org!!!

Actions #32

Updated by Fernando Hartmann almost 13 years ago

+1 This should be in Redmine basic features !

Actions #33

Updated by Fernando Hartmann almost 13 years ago

Are someone using this plugin with Redmine 1.2.0, where is it available to download ?
I Found only a updated up to 2009 in https://github.com/Ubik/redmine_vote !!
Is it abandoned ?
If so, we need to reopen this ticket !

Actions #34

Updated by Kurt Christensen over 12 years ago

I nice guy forked the original redmin_vote plugin, and his fork is working for me. I'm running Redmine 1.2.1 on Ubuntu 10 with MySQL.

Actions #35

Updated by Kurt Christensen over 12 years ago

Urmf. Sorry for the garbled previous post. Here's the link to the nice guy's fork of redmine_vote:

https://github.com/jimmyz/redmine_vote

Actions #36

Updated by Terence Mill over 12 years ago

I am working on a fork with missing features
https://github.com/cforce/redmine_vote

  • per project module which can be switched on/off
  • added 3 rights
    • vote_issue
    • view_votes
    • view_voters
      separated view from hook code, no more inlining
      TODO:
  • fix #2 bug for public projects
  • establish view_rights for issues vote patch
  • provide filters for issue search
Actions #37

Updated by Deniz Bahadir about 12 years ago

Sascha Herrmann wrote:

+1 for activating this feature on redmine.org!!!

I will do the same:
+1 for activating this feature on redmine.org!!!

Actions #38

Updated by Jonathan East almost 12 years ago

+1 for activating this feature on redmine.org

Actions #39

Updated by Aidin Abedi almost 12 years ago

+1

Actions #40

Updated by Aidin Abedi almost 12 years ago

  • Status changed from Closed to Reopened
  • % Done changed from 100 to 0

Since the "vote plugin" referenced as reason for closing this issue hasn't been maintained in over 3 years. I strongly urge this feature be reopened and reconsidered as part of redmine core. This is a essential feature, trac even has it as part of there official tracker. This is a must have for any large organisation or public project.

EDIT: also I think all everyone would appreciate this over spamming "+1" for everything.

Actions #41

Updated by K. Scott Tripp over 11 years ago

More "+1" spam!

Actions #42

Updated by Roger Müller over 11 years ago

+1

Actions #43

Updated by Fred Leeflang over 11 years ago

+1

Actions #44

Updated by Daniel Felix over 11 years ago

+1 relates to #11655 and #6945.

Actions #45

Updated by Antoine Beaupré about 11 years ago

+1

one way i'd like to see this implemented is by simply displaying the number of watchers on an issue... we already have a voting system builtin, right there. plus it means that people that vote actually are involved in the issue because they receive updates. if they don't want to receive updates, maybe they don't care so much. :)

Actions #46

Updated by Terence Mill about 11 years ago

Actions #47

Updated by Sandro Camarao about 11 years ago

+1

Actions #48

Updated by Thomas Robbs almost 11 years ago

“Yo Dawg, I herd you like +1, so I put a +1 in your +1 so you can +1 while you +1.”

+1 for the +1 feature

Actions #49

Updated by Eugene Fokin almost 11 years ago

+1

Actions #50

Updated by D K almost 11 years ago

+1

Actions #51

Updated by Željko Trogrlić over 10 years ago

Activate plugin so we are sure that it will be upgraded to future Redmine versions.

Actions #52

Updated by Toshi MARUYAMA over 10 years ago

  • Status changed from Reopened to New
  • Resolution deleted (Wont fix)
Actions #53

Updated by Toshi MARUYAMA over 10 years ago

Actions #54

Updated by Anonymous over 10 years ago

+1

Actions #55

Updated by Aidin Abedi over 10 years ago

+1 (Unfortunately, I'm assuming the redmine devs will never be interested in adding this...)

Actions #56

Updated by Anonymous over 10 years ago

+1 (I'd vote for it, but I can't)

Actions #57

Updated by Jeff W over 10 years ago

+1 (if this is the kind of voting...)

Actions #58

Updated by Deoren Moor almost 10 years ago

+1

Actions #59

Updated by Robert Pollak almost 10 years ago

I am also affected by this.

Btw., launchpad.net instead has a clickable
"This bug affects 34 persons. Does this bug affect you?".

Actions #60

Updated by Robert Pollak almost 10 years ago

Alternatively, one can "Use Watcher Count as a poor man's Voting system" (issue #17288)

Btw., #11655 is a duplicate of this issue.

Actions #61

Updated by Toshi MARUYAMA almost 10 years ago

  • Related to deleted (Feature #11655: Implementation of a Issue Voting)
Actions #62

Updated by Toshi MARUYAMA almost 10 years ago

  • Has duplicate Feature #11655: Implementation of a Issue Voting added
Actions #63

Updated by Toshi MARUYAMA almost 10 years ago

  • Related to Feature #17288: Use Watcher Count as a poor man's Voting system on redmine.org added
Actions #64

Updated by Kevin Palm almost 10 years ago

+1

Actions #65

Updated by asd asd over 9 years ago

+1

Actions #66

Updated by James H about 9 years ago

+1

Actions #67

Updated by CH fish almost 9 years ago

+1
I hope it will be around rather sooner then later...

Actions #68

Updated by budo kaiman almost 9 years ago

+1

Actions #69

Updated by Alexander Watzinger over 8 years ago

+ 1

Actions #70

Updated by Anton Reutov over 8 years ago

+1

Hi,
Dear Developers, when this module will be create ?

2008-04-07 - it is not ok
This request already exists 8 years old

Actions #71

Updated by Simon Cruise over 7 years ago

We have always performed prioritisation of issues politically within the business and weight each channel with importance.

For example the sales team will never vote to have a db query optimised.

Priorities are extremely useful to a point but when you have queues with hundreds of items it is nice to have a group voting system to allow this to be taken into account.

The way I would love to see it implemented is that it would be a custom field, essentially an Integer type with vote controls assigned to it. i.e. Format type would be vote.

The default value could always be 0 and the following could be left out :

Min - Max length
Regular expression
Default value
Link values to URL

Other than that it could hopefully piggy back off the Integer type logic already in place.

Actions #72

Updated by Konstantin Ladutenko over 7 years ago

The possible design solution I had created for a duplicated issue Feature #24946 (it has a more detailed description of the feature request, is is actually not a full duplicate of the present issue, as it is about adding voting to the issue list, not to the issue view itself)

Actions #73

Updated by Toshi MARUYAMA over 7 years ago

  • Related to Feature #24946: Issue rating (like button or vote up button) added
Actions #74

Updated by Anonymous almost 6 years ago

+1

Actions #75

Updated by Antoine Beaupré over 5 years ago

Max Johansson wrote:

+1

See, this is beyond irony at this point. This issue is close to receiving about a hundred +1 comments, most of which are unnecessary noise for probably even more watchers that have been waiting for this issue to be fixed for over a decade now.

It's simply a matter of showing the number of watchers on an issue. How hard can that possibly be? :)

That said, I'm not using Redmine anymore, and so I will bid my fellow watchers farewellm, unwatch this issue and apologize for this final, ultimate mike drop:

+1

:)

Actions #76

Updated by Anonymous over 5 years ago

Antoine Beaupré wrote:

unwatch this issue and apologize for this final, ultimate mike drop: +1 :)

LOL XD

Actions

Also available in: Atom PDF